#!/usr/bin/make -f
# -*- makefile -*-
# Sample debian/rules that uses debhelper.
# This file was originally written by Joey Hess and Craig Small.
# As a special exception, when this file is copied by dh-make into a
# dh-make output file, you may use that output file without restriction.
# This special exception was added by Craig Small in version 0.37 of dh-make.
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
export DEB_PYTHON_SYSTEM=pysupport
# Debhelper must be included before python-distutils to use
# dh_python / dh_pycentral / dh_pysupport
include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/python-distutils.mk
# clean the manpage
clean::
make -C man clean
# build the manpage
build/pycam::
make -C man
# install the .desktop file
install/pycam::
cp -v desktop/pycam.desktop `pwd`/debian/pycam/usr/share/applications/
rm -rf `pwd`/debian/pycam/usr/share/pycam/doc
-
sumpfralle authored
git-svn-id: https://pycam.svn.sourceforge.net/svnroot/pycam/trunk@616 bbaffbd6-741e-11dd-a85d-61de82d9cad9
bea15510