#!/usr/bin/make -f
# -*- makefile -*-
# Sample debian/rules that uses debhelper.
# This file was originally written by Joey Hess and Craig Small.
# As a special exception, when this file is copied by dh-make into a
# dh-make output file, you may use that output file without restriction.
# This special exception was added by Craig Small in version 0.37 of dh-make.

# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1


export DEB_PYTHON_SYSTEM=pysupport

# Debhelper must be included before python-distutils to use
# dh_python / dh_pycentral / dh_pysupport
include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/python-distutils.mk

# clean the manpage
clean::
	make -C man clean

# build the manpage
build/pycam::
	make -C man

# install the .desktop file
install/pycam::
	# "desktop" file
	cp -v share/desktop/pycam.desktop `pwd`/debian/pycam/usr/share/applications/
	# application logo for the menu entry
	cp -v share/ui/logo_scalable.svg `pwd`/debian/pycam/usr/share/icons/hicolor/scalable/apps/pycam.svg
	# remove "doc" directory from /usr/share/pycam/
	rm -rf `pwd`/debian/pycam/usr/share/pycam/doc
	# the CXF fonts are distributed by QCAD - use them instead of the embedded ones
	rm -rf `pwd`/debian/pycam/usr/share/pycam/fonts
	# the gtkrc file for Windows is useless
	rm `pwd`/debian/pycam/usr/share/pycam/ui/gtkrc_windows